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5.0
Overview

About SDI

The Spatial Data Interface (SDI) component of Infra was developed to manage and maintain spatial data within Infra.  The target user of this toolset is the spatial data manager, who may be a GIS specialist or a user from a functional area such as Engineering or Recreation.

To integrate spatial data into Infra, the data must meet basic requirements.  A link must be established between the spatial data and Oracle tabular data, and the spatial data must be of accuracy and integrity equal to the tabular data.  The SDI toolset was developed to help meet these requirements.

SDI is a modified version of the Topological Editing System (TEDS), developed by the University of Tennessee for the Federal Highway Administration and promoted as a toolset for Route Spatial Data Preparation.  The TEDS interface is a generic toolset with functionality across the board for GIS data preparation and maintenance.  SDI built upon the basic functionality of TEDS and added tools for spatial data management within the Infra application.

SDI is primarily a front end to ArcEdit, with tools to access ArcInfo and ArcPlot.  This chapter assumes the user has a basic to moderate familiarity with GIS data support and maintenance, and some knowledge of ArcInfo and ArcEdit.

System Requirements

SDI is a set of Arc Macro Language AML) code that expands the abilities of ArcInfo and ArcEdit.  SDI utilizes the ArcInfo command library and Arc Tools library.

The Infra installation provides the basic settings necessary for SDI to run; however, some aspects of a server cannot be validated during install. To ensure a proper working environment for SDI, some additional items may be checked.

ArcInfo Version

SDI Version 1.0 runs under ArcInfo 7.1.1 or later.  The $ARCHOME system variable must be set to the location of ArcInfo 7.1.1.  The $ATHOME system variable must be set to the location of Arc Tools.  These are system global variables set during server start-up, and should not be changed by the user.  ArcInfo 7.1.1 (or later) should be the only version of ArcInfo on the server.

Customized User Environment

AIX permits users to customize their working environment on many levels.  The areas that most directly affect the operation of SDI are the kshrc, cshrc, arc, and arcedit files.  If problems are encountered while running SDI, rename these files to a temporary name and restart SDI to see if the problem is resolved.

Changes to the standard FS Image on the server can also cause problems with SDI.  Verify that the $ARCHOME, $ATHOME, kshrc, cshrc, arc, arcplot, tables and arcedit files in the server environment are the standards and have not been modified.  There have been Forests that have made modifications to their ARC.AML in the $ARCHOME directory.  These modifications cause problems with SDI and should be removed before running SDI.

Basic Rules of Operation

SDI, as a graphical user interface to ArcEdit, includes many commands in the form of selection menus, pull-down menus, and button tool bars.

Click on a button with the right mouse button to display a brief description of the button's function.

When selecting from menus, if multiple menu windows are available, always select from left to right.

If a command is available through a menu or button bar, use it there rather than going to the ArcEdit command window.  Many SDI commands build upon each other and using the command window bypasses this feature.  The ArcEdit command window is intended for use with ArcEdit commands not available in Windows, or for basic commands such as "select" and "calc".

5.1
Using SDI

Required Roles

To use SDI, you must have AIX Write privileges for the current workspace and coverage.  Although SDI will allow you to set your workspace and coverage where you only have Read privilege, you must have Write privilege to edit a coverage and save your changes.
To Start SDI

There are three ways to start SDI.

From a Windows icon:

	Step
	Description

	1.
	Open the Infra folder by double-clicking the icon on your Windows desktop. [image: image1.png]




	2.
	Double-click on the SDI icon. [image: image2.png]




	3.
	If you have not already logged into your IBM server with Exceed, wait a moment for your IBM login to appear, enter your username and password, then allow the login to complete before proceeding with step 4.

	4.
	Enter your server name, username, and password, and then press OK.
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From the Infra Main Menu:

	Step
	Description

	1.
	Click on [image: image4.png]


 from the Infra Main Menu.  Refer to Chapter 1 for the steps to access the Infra Main Menu.


From Exceed:

	Step
	Description

	1.
	Open the Office Applications menu from the Front Panel (Click on [image: image5.png]


 the [image: image6.png]


 above).

	2.
	Click on [image: image7.png]i
#pp ban




.

	3.
	Double click on [image: image8.png]Forest_Service



.

	4.
	Double click on [image: image9.png]AssetManagement



.

	5.
	Double click on [image: image10.png]


 to reach the Infra Application Manager screen.

	6.
	Double click on [image: image11.png]®

Spatial Data Interface



 to go directly to the SDI screen (Figure5.1 below)


Screen Definitions (SDI)
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Figure 5.1:
The SDI screen

The Main Menu Bar
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The main SDI menu bar, which appears at the top of the SDI screen, is described in detail in Section 5.2.  To select a function, move your cursor to that function and click.  Some menu items contain a drop-down menu of additional choices.  Point your cursor and click again to make a selection.  When selecting from menus, if multiple menu windows are available, always select from left to right. 

The Default Tool Bar

The default tool bar, on the left below the main menu bar, contains buttons frequently used for general operations.  See Section 5.2 for detailed descriptions of each option.
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The Zoom Tool Bar

The zoom tool bar, in the center of the screen below the main menu bar, contains buttons used to alter the area displayed on the screen.  See Section 5.2 for detailed descriptions of each option.
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Edit Tool Menu Bar

The Edit Tool menu bar, on the right below the main menu bar, contains menu choices for editing spatial features.  See Section 5.2 for detailed descriptions of each option.
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Note: Although the Routes option, on the Edit Tool menu bar above, contains tools for dynamically segmented route work, these selections are general route tools that do not pertain specifically to Infra Travel Routes.  Some of these tools may prove helpful, however, it is recommended you do NOT use the re-measure tools for road and trail routes, as they calibrate differently than the method used in Infra Travel Routes. 

Status Bar

The Status Bar normally displays the current edit cover, edit feature, number of selected features, and draw environment.  This window also provides valuable information, including warnings and error messages.  It is important to check the status bar often as you work in SDI.

5.2
SDI Functionality

Main Menu Bar

This section describes the options on the SDI main menu bar. 

File-> Data Catalog
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Figure 5.2:
The Data Catalog

To Access the Data Catalog

	Step
	Description

	1.
	From the main menu bar on the SDI screen, click on File, then Data Catalog (from the drop-down menu) to display Figure 5.2 above.


Each choice on the Data Catalog form is described below.

Data Catalog: Select a Coverage to Edit

Use this option to select coverage from the Data Catalog to edit.  Clicking on this option reveals a list of the coverage’s currently defined in the Data Catalog (Figure 5.3).  Use the scroll bars to scroll through the list.  Note: although the Data Catalog tracks shape files as well as coverages, shape files are not listed in this menu because SDI cannot edit them.

[image: image19.png]SDI: Data Catalog Selection

=]

Select a Coverage to Edit from the Data Catalog:

Thene Name Subclass Coverage w/Path

[Cal Vegetation /¥sFiles/ref/ Library/gis/shnf/bdfcuegd503
Developed Recreation Sites  POINT /fsfiles/ref/library/gis/shnf/bdfdrec802
Ecosystens POLYGON /8sfiles/ref/library/gis/shnf/bdfecos9804
Fire Dispatch Areas POLYGON /8sfiles/ref/library/gis/shnf/bdfdisp9701
Fire Stations POINT /8sfiles/ref/library/gis/shnf/bdfEstad61l
OHY Impact Areas POLYGON /8sfiles/ref/library/gis/shnf/bdfohiad706
Roads ROUTE  ERDS /esfiles/ref/library/gis/stanis/storoute
Soils POLYGON /8sfiles/ref/library/gis/shnf/bdfso0il9701
Stewardship Areas POLYGON /8sfiles/ref/library/gis/shnf/bdfstend610
Trails ROUTE  FTRL /Estiles/ref/library/gis/stanis/storoute

FI

Apply]

Cancell

T




Figure 5.3:
Data Catalog Selection Screen

To Select an Edit Coverage

	Step
	Description

	1.
	Click on the coverage name, and then click on Apply.  The edit coverage is set to the selected coverage name, the workspace is set to the selected coverage location, and the edit feature is set to the edit feature/subclass.


You will be prompted to set the extents to that of the selected coverage.  If a saved environment exists for the selected coverage, you are prompted to restore it.

Data Catalog Management

The Data Catalog manages information about coverages and shape files.  One coverage may be defined multiple times, once for each feature type.  The Management option defines and manages spatial data within the Data Catalog.  The first time this option is selected within SDI, the Data Catalog files are created.  All SDI users use one set of Data Catalog files.  The Data Catalog Management form is displayed below.
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Figure 5.4:
Data Catalog Management Form

The first line on the form shows the number of records currently being processed as the result of a query.  If new records are being entered, this line will show “Record 0 of 0 Selected Records”.  This line also displays the total number of records currently in the Data Catalog.  The next line displays the current work session status.  “Adding New Records” indicates that new entries are being made into the Data Catalog.  “Modifying/Viewing Existing Records” indicates existing Data Catalog entries have been queried.  The remaining fields are described below.

Field Definitions

	Field
	Definition
	Notes

	Record ID Number
	Each record in the catalog is automatically assigned an identification number.  These are sequential numbers used to process the entries, and if you are duplicating records for modification they can be helpful in finding the new record.
	System Generated

	Title
	Enter a title for the theme.  This title is used to describe the theme when listed in SDI and ArcView.
	Mandatory

	Feature Type
	Displays the type of feature in the theme: ARC, POINT, POLYGON, ROUTE, ANNO, REGION, and SHAPE.  Click with the right mouse button to display a list of valid values.
	Mandatory

List of Values

	File & Path
	Enter the complete path and name of the theme.  A valid coverage or shape file must be entered.  Click with the right mouse button to display a navigation menu to locate the coverage or shape file.
	Mandatory

	Feature Subclass
	For the theme types ANNO, REGION, or ROUTE, enter a subclass.  The catalog will validate that this subclass exists in the coverage.  Click with the right mouse button to display a list of current subclasses in the coverage.
	Mandatory for ANNO, REGION, and ROUTE.

List of Values

	Point Mgt Method
	For Point themes, enter the point management method used to manage the theme:

A - Route point events

B - Dynamically created coverage

C - Dynamically created coverage using offsets

D - Maintained coverage

Click with the right mouse button to display a list of valid values.  See the SDI chapter of the Infra Travel Routes User Guide for more information on Point Management Methods.
	Mandatory for POINTS.  

List of Values

	Status
	Enter the status of the theme:

DYNAMIC - a temporary theme created as needed, as a subset of another theme.  Dynamic themes should not be edited in SDI.

MAINTAINED - a master theme that is maintained using SDI or ArcEdit.

Click with the right mouse button to display a list of valid values.
	Mandatory

List of Values

	Object Class & Name
	Enter the subject (i.e., Road, Trail, RMU) of the theme corresponding to the objects listed in Infra.  If the theme does not represent information managed within the Infra database, leave this field blank.  Click with the right mouse button to display a list of the current objects entered in the local system, obtained from Oracle.
	Infra connected coverages Optional 

List of values

	Oracle Table/View
	Enter the name of a table or view in Oracle that contains attribute data for the theme.  If the Object Class and Name are filled out for an Infra coverage connected to the database, this field is automatically filled in with the corresponding table or view for that object.  Click with the right mouse button to display a list of views currently present in Oracle.

This field and the following two fields contain information necessary for the ArcView Infra Data Catalog to automatically download data from Oracle and join it to the theme for display and query.  
	Optional

List of Values

	Oracle Join Item
	The name of the item in the Oracle table or view that relates to an item in the theme.  If the Object Class and Name are filled out for an Infra coverage connected to the database, this field is automatically filled in with the corresponding join item for that object.  Click with the right mouse button to display a list of items in the table or view.
	Optional

List of Values

	Theme Join Item
	The name of the item in the theme that relates to an item in the Oracle table or view.  If the coverage is connected to Infra, the Theme Join Item is probably "CN#" or "RTE_CN."  This item is necessary for themes that are not connected to Infra but are linked to an Oracle table.  Click with the right mouse button to display a list of items in the theme.
	Optional

List of Values

	Properties
	Opens the Data Catalog Theme Properties form, which lets you define one or more schemes for displaying the theme in ArcView or ArcPlot.  After exiting the Theme Properties form, control returns to the Data Catalog Management Form.
	Optional, Opens New Form

	Created By
	The name of the user who entered the theme is automatically displayed when the entry is committed.
	System Generated

	Created Date
	The date the theme was entered is automatically displayed when the entry is committed.
	System Generated

	Modified By
	If the theme information is modified, the name of the user making the modification is automatically displayed when the change is committed.
	System Generated

	Modified Date
	If the theme information is modified, the date of the modification is automatically displayed when the change is committed.
	System Generated

	First/Next/

Previous
	Click on these buttons to scroll through queried records.  First will move to the first record in the query, Next moves to the record following the one currently displayed, and Previous moves to the record preceding the one currently displayed.  ID Number sorts records.
	

	Find Existing Records
	Click on Find All to query all records currently in the catalog.  Use First, Next, and Previous to scroll through the queried records.
	

	Edit Existing Records
	Click on Delete to delete the currently displayed record.
	

	Add New Records
	When the Status at the top of the screen is "Adding New Records", click on Clear to clear all fields on the form and begin entering a new record.   Click on Duplicate to create a duplicate of the currently displayed record.
	

	Commit
	Commits all changes to the Data Catalog and clears the form.
	

	Done: Commit all Changes
	Commits all changes to the Data Catalog and exits the form.
	

	Cancel: Do NOT Commit Changes
	Exits the form without committing any changes.
	


To Enter a New Theme

	Step
	Description

	1.
	When the Data Catalog Management form (Figure 5.3) is first displayed, you are positioned on a blank record.  If you have already entered information, or have queried records, click on Clear to clear the form and display a blank record.

	2.
	Enter each field in the order it appears, beginning with Feature Type.  Click with the right mouse button to display a list of valid values where applicable.  Or, click on Duplicate to create a duplicate of the theme currently displayed.

	3.
	When all fields have been entered, click on Commit to save your changes to the Data Catalog and remain in this form, or click on Done: Commit All Changes to save your changes and exit the form.


To Query or Edit Existing Theme Information

	Step
	Description

	1.
	In a blank form, click on the Search button to the right of the field to query.  A pop-up menu will display a list of available values for the search.  Records meeting the search criteria will be returned.  Theme information may also be queried using the Find All button at the bottom of the form.  Find All queries all records in the catalog.

	2.
	The top of the form tells you how many records were queried.  Scroll through the queried records using First, Next, and Previous to find the record to be edited.  

	3.
	Make any changes, and then click on Commit to save your changes to the Data Catalog and remain in this form, or click on Done: Commit All Changes to save your changes and exit the form.
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Figure 5.5:
The Data Catalog Theme Properties form

The Data Catalog Theme Properties form contains information about how to display the theme in ArcView or ArcPlot.  Using data entered on this form, the ArcView Data Catalog can apply a default legend, set label items, and minimum and maximum display scale, or link the features in the theme to digital images.  You may create one or more sets of properties for a theme.  Defining multiple sets of properties gives ArcView users a choice of how to display the theme (with different legends or scales, for example).  This form is optional - a theme does not require a set of properties and not all the properties need to be filled out in the form.

Field Definitions

	Field
	Definition
	Notes

	Alternate Title
	Enter a title for this set of properties.  This is the name the ArcView Data Catalog will use to identify the set of properties, and the title applied to the theme in the ArcView table of contents.  If left blank, ArcView will use the Title entered on the Data Catalog Management form.
	

	Legend / Key Item
	Enter the name of the field used to classify the legend.  Click with the right mouse button to see a list of fields in the theme (and in the related Oracle table or view if one was set up on the Data Catalog Management form). 
	Mandatory for AP Keyfile.

List of Values

	AV Legend File
	Enter the complete path and name of the ArcView legend file (*.avl) to be used with this theme.  Click with the right mouse button to display a navigation menu to locate the legend file.
	

	AP Keyfile
	Enter the complete path and name of the ArcPlot keyfile to be used with this theme.  Click with the right mouse button to display a navigation menu to locate the key file.
	

	AP Symbol Set
	Enter the name of the ArcPlot symbol set to be used in combination with the Keyfile.  Click with the right mouse button to display a navigation menu to locate symbol sets.
	

	Label Field
	Enter the name of the field with values to be displayed using the ArcView Label Tool and Auto-Label.  Right-click to see a list of fields in the theme (and in the related Oracle table or view if one was set up on the Data Catalog Management form). 
	List of Values

	Minimum Scale
	In ArcView, the scale at which the theme will be drawn when the view's scale is smaller.  For example, to stop displaying the theme when zoomed in closer than 1:24,000, enter 24000.
	

	Maximum Scale
	In ArcView, the scale at which the theme will be drawn when the view's scale is larger.  For example, to stop displaying the theme when zoomed out further than 1:50,000 enter 50000.
	

	Hot Link Field
	Enter the name of the field to be used by the Hot Link script when the ArcView Hot Link tool is applied.  The value is usually a file name that is then opened and displayed (for example, image file names with full paths).  Click with the right mouse button to see a list of fields in the theme (and in the related Oracle table or view if one was set up on the Data Catalog Management form). 
	List of Values

	Hot Link Script
	Enter the name of an Avenue script to run when the Hot Link tool is applied.  ArcView includes some Hot Link scripts, including Link.ImageFile to display images, and Link.TextFile to display text files.
	

	Definition Query
	Enter an ArcView QueryBuilder string that will restrict the display of features in the theme.  For instance, to display only polygons larger than 100 square meters, enter:  [area] > 100
	

	Default Settings
	Click the Y button to identify this as the default set of properties for the theme.  The default properties will be applied to the initial theme in the ArcView Data Catalog.  Sets of properties that are not default can be applied by changing the legend for the theme once it is loaded in a view.
	Defaults to N.

	First/Next
	Click on these buttons to scroll through properties records for the theme.  First will move to the first properties record created, Next moves to the record following the one currently displayed.
	

	Add
	Create a set of properties for the current theme.  Start with a blank form.
	

	Duplicate
	Create a set of properties for the current theme.  Start with a duplicate copy of the current set of properties.
	

	Delete
	Will delete the current properties record from the data catalog.  The information will be deleted from the form and a blank form for the theme will remain.
	

	Done
	Close this form and return to the Data Catalog Management form.  All changes made on the Data Catalog Theme Properties form are applied immediately.  There is no need to save before closing this form.
	


Data Catalog Backup

Regular backups of the Data Catalog are recommended.  The Backup option creates Arc export files of the Data Catalog Info files.
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Figure 5.6:
The Data Catalog Backup

To Create a Backup

	Step
	Description

	1.
	Select a workspace for the backup files (Figure 5.6 above) and click on Apply.


The two export files are named 'dc' and 'ddc', followed by the current date (YYYYMMDD) and version number (00, 01, 02,).  A backup file created on June 17, 1998 would be named "dc1998061700.e00".  A second backup created on the same day in the same directory location would be named "dc1998061701.e00".  For easier management, all backups should be placed in the same directory.
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Figure 5.7:
The Data Catalog Backup continued

Data Catalog Restore

The Restore option deletes the current Data Catalog and replaces it with a backup version.  This option should be used with caution.
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Figure 5.8:
The Restore Data Catalog

To Restore a Backup Version of the Data Catalog

	Step
	Description

	1.
	Navigate to the directory location and select a backup file (Figure 5.8 above). Click on Apply.

	2.
	A confirmation message warns the backup file will overwrite the current Data Catalog (Figure 5.9 below).  To continue, click on Yes.  To cancel, click on No.
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Figure 5.9:
The Restore Confirmation

File -> Workspace
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Figure 5.10:
The Change Workspace

To Set the Workspace

	Step
	Description

	1.
	Select a directory by clicking from the list in the window box on the left. Use the [image: image28.png]


 button to move up one directory.

	2.
	When the correct directory has been selected, click on Apply.  The window displays the coverages in the current directory, and selecting one will set the edit coverage.


File -> Cover
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Figure 5.11:
Select an Edit Cover 

To Select an Edit Coverage

	Step
	Description

	1.
	Use the scroll bars to locate an edit coverage, and click on the coverage to select.  You may also type the complete path and coverage name in the path window.

	2.
	When the correct path and coverage have been selected, click on Apply.  You will be prompted to set the default map extents to the extents of the selected coverage.


File -> Remove

[image: image31.png]File Edit View Back Env Select Identify Tahles Geography Dynleg Utilities Windows Help

Data Catalog

Workspace

Cover

Remove 3 Seclect Remove from the File menu to remove the edit coverage from
Save the editing session. The screen displays a list of the coverages

Save As which have been edited during the current SDI session (Figure 5.12).
Backup

Environment

Exit




[image: image32.png]E Remove Edit Cover

Select An Edit Coverage To Remove!

[/FSETLES/REF/LIBRARY/ GES/SENE /BDECATGS703

[/FSFILES/REF/LIBRARY/GIS/SBNE/BDECATGS703
/FSFILES/REF/LIBRARY/GIS/SBNE/BDFTRALS706

s T

FI I}

Apply| Cancell





Figure 5.12:
Remove Edit Cover 

To Remove an Edit Coverage

	Step
	Description

	1.
	Click on the edit coverage to be removed, and then click on Apply.  You will be prompted to save any changes before removing the coverage. 

If the coverage removed was the current edit coverage, Figure 5.11 will be displayed, prompting you to select a new edit coverage.


File -> Save and Save As
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Figure 5.13:
Save as 

To Save an Edit Coverage to a New Name

	Step
	Description

	1.
	Click on File, then Save As.

	2.
	Enter a new name for the coverage, and then click on Apply.

	3.
	Figure 5.10 will be displayed, prompting you to select a new workspace for the coverage.


File -> Backup
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File -> Environment
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Figure 5.14:
Environment

To Save an Environment

	Step
	Description

	1.
	Click on File, then Environment.

	2.
	Click on Save Environment.  If an environment has already been saved for the current edit coverage, you will be prompted to overwrite the previous environment.


To Retrieve an Environment

	Step
	Description

	1.
	Click on File, then Environment.

	2.
	Click on Retrieve Environment.  If an environment has been saved for the current edit coverage, it is restored into the current SDI session, overwriting any previous settings.


File -> Exit - Select Exit from the File menu to exit the SDI application.  If an edit mask exists on the current edit coverage, you will be prompted to save your changes before exiting.  

Edit

Edit -> Edit Feature
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Figure 5.15:
Edit Features

To Select an Edit Feature

	Step
	Description

	1.
	Click on Edit, and then Edit Feature.

	2.
	Click in the box to the left of a feature type to select it, or click on Back to Main Menu to exit without changing the current edit feature.  


Edit -> Edit Distance
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Figure 5.16:
Edit Distance

There are three choices:

Default - Sets the edit distance to the default value (1/100th of the coverage width or height extent in coverage units, whichever is greater).  Note: This value is automatically updated if the coverage extent changes.

Define with Cursor - Allows the edit distance to be set by selecting two points defining the radius of a circle in the display window.  Position the cursor at the center of the desired circle and click, then drag the circle to the desired radius and click again.


Note: the dialog box can be dragged aside if necessary.

Distance - Allows the edit distance to be entered directly in the units of the coverage.

Edit -> Snap Tolerance
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Figure 5.17:
Snap Tolerance

There are six choices:

Closest - Enables snapping, and sets the search method to use the closest feature found within the snapping tolerance.

First - Enables snapping, and sets the search method to use the first feature found within the snapping tolerance.

Off - Disables snapping.

Default - Sets the snap distance to the default value (1/1000th of the coverage width or height extent in coverage units, whichever is greater).  Note: this value is automatically updated if the coverage extent changes.

Define with Cursor - Allows the snap distance to be set by selecting two points defining the radius of a circle in the display window.  Position the cursor at the center of the desired circle and click, then drag the circle to the desired radius and click again.  The dialog box can be dragged aside if necessary.

Tolerance - Allows the snap distance to be entered directly, in the units of the coverage.

Edit -> Intersect Arcs
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Figure 5.18:
Intersect Arcs

Edit -> Edit Symbol - Select Edit Symbol from the Edit menu to choose the line type and color to symbolize features that have been edited since the last save.

To Set the Edit Symbol

	Step
	Description

	1.
	Click on Edit, and then Edit Symbol.

	2.
	Select a line type style from the box to the left, then select a color from the box on the right and click on Apply.


View

View -> Display
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Figure 5.19:
Display Menu

Each option on the Display menu is described below:

Display: Draw Environment - Use to select the features to be drawn.  Only the features valid for the current edit cover will be listed.   In Figure 5.20 below, Arcs and Nodes are selected.
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Figure 5.20:
Draw Environment

To Set the Draw Environment

	Step
	Description

	1.
	Click on View, then Display, and then click in the box by Draw Environment.

	2.
	Click in the box to the left of each feature type to select it, and then click on Back to Display Menu to return to the Display Menu.


Display: Symbol Colors - Use to select the color and symbol for the features to be drawn.  The feature color may not be changed for nodes, unless a node attribute table exists.  Multiple feature colors may be set by selecting apply after each feature type and color selection.
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Figure 5.21:
Symbol Colors

To Select Symbol Colors

	Step
	Description

	1.
	Click on View, then Display, and then click in the box by Symbol Colors.

	2.
	Click on a feature in the left box (scroll to display more features), and then click to select a feature color and symbol from the right box.

	3.
	Click on Apply to save this selection, and repeat step 2 to select symbol colors for additional features if necessary.  Click on Apply after each selection.

	4.
	Click on Back to Display Menu to return to the Display Menu.


Display: Pseudo Nodes and Dangles - Use to select the color and symbol for pseudo nodes and dangling nodes.
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Figure 5.22:
Pseudo Nodes and Dangles

To Select Symbol Colors for Pseudo Nodes and Dangles

	Step
	Description

	1.
	Click on View, then Display, and then click in the box by Pseudo Nodes and Dangles.

	2.
	Click on a feature in the left box (scroll to display more features), and then click to select a feature color and symbol from the right box.

	3.
	Click on Apply to save this selection, and repeat step 2 to select symbol colors for additional features if necessary.  Click on Apply after each selection.

	4.
	Click on Back to Display Menu to return to the Display Menu.


Display: Text Items - Use to select text items for features.

To Select Text Items for a Feature

	Step
	Description

	1.
	Click on View, then Display, and then click in the box by Text Items. (Figure 5.23)

	2.
	Click on a feature in the left box, and then click in the right box to select the item whose value will be displayed.

	3.
	Click on Apply to save this selection.  Use the text off button to turn text off.

	4.
	Click on Back to Display Menu to return to the Display Menu.
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Figure 5.23:
Text Items

Display: Symbol Items: Use the to select symbol items for features.

To Select Symbol Items for a Feature

	Step
	Description

	1.
	Click on View, then Display, and then click in the box by Symbol Items. (Figure 5.24)

	2.
	Click on a feature in the left box, and then click in the right box to select the item whose value will be used for symbolizing the feature.  Symbol items are displayed based upon the currently selected symbol set.  Symbol sets are selected under Options, Symbol Sets (described later in this section).

	3.
	Click on Apply to save this selection.  Use the text off button to turn text off.

	4.
	Click on Back to Display Menu to return to the Display Menu.
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Figure 5.24:
Symbol Items

Display: Events: Use to select events for display by symbol item and lookup table.  The default symbol color (without a lookup table) is red. The current edit feature must be Route. <subclass>. Events will continue to draw via an ArcPlot macro until View Events is toggled OFF.

View -> Options
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Symbol Sets - Use this option to select symbol sets for lines, markers, and shades.

To Select a Symbol Set

	Step
	Description

	1.
	Click on View, then Options, then Symbol Sets. (Figure 5.25)

	2.
	Click on a symbol type (line, marker, or shade) in the left box, and then click in the center box to select a symbol set.  The right box displays the symbols and colors for the selected symbol set.  When a symbol set is selected, it is immediately applied.

	3.
	To discard that symbol set, click on Discard Changes.
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Figure 5.25:
Symbol Sets

Highlight Colors - Use this option to select the symbol and color for highlighting selected features.

To Select a Highlight Color

	Step
	Description

	1.
	Click on View, then Options, then Highlight Colors.  (Figure 5.26)

	2.
	Click on a symbol type in the left box, and then select a color from the right box and click on Apply.
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Figure 5.26:
Highlight Colors

View -> Zoom In - Use the cursor to point to a location to zoom in to, and enter "9" to quit zooming in.
View -> Zoom Out - Use the cursor to point to a location to zoom out to, and enter "9" to quit zooming out.
View -> Zoom Box - Zoom into features by defining a box around the area of interest. Use the cursor to select diagonally opposite corners of the extent of the box.
View -> Zoom To Selected - Zoom to the extent of the selected features.

View -> Zoom To Previous - Zoom back to the previous view extent.

View -> Zoom To Maximum - Zoom to the maximum map extent of the edit cover.

View -> Pan By Pointing - Point the cursor to a new location to center in the view.  Enter 9 to quit panning.

View -> Pan By Grabbing

Pan by using the cursor to grab and drag the display. Enter a 9 to quit panning.

View -> Clear Screen - Clear the display window.

View -> Refresh Screen - Redraw features in the display window.

Background Environment

Back Env -> Covers
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Figure 5.27
Background Environment

To Select Background Covers

	Step
	Description

	1.
	Click on Back Env, then Covers.

	2.
	Workspace: type the path to the parent directory of the background cover you desire.  Previously defined system variables may be used for all or part of the path.

	3.
	Select a Back Cover: type the background cover name, or right-click in the window for a list of coverages in the specified Workspace.  Left-click on a coverage to move it into the scrolling list of Background Covers in the center of the screen.  You may select up to 50 background covers.  For each cover, you may change the parent directory in the Workspace window.

	4.
	Draw Environment: Click on a background cover in the scrolling list in the center of the screen, then click on Draw Environment to choose the features to draw.  To select a feature, click on corresponding check box.

	5.
	Feature Colors: Click on a background cover in the scrolling list in the center of the screen, and then click on Feature Colors to select the symbols and colors for the features selected above.  First select a feature from the left box, and then choose the feature color and symbol from the right box.

	6.
	Click on Back to Main Menu to accept your settings and return to the Main Menu.


To Remove Background Covers

	Step
	Description

	1.
	Click on Back Env, then Covers.

	2.
	Background Covers:  Click on a background cover in the scrolling list in the center of the screen, and then click on Remove Backcover to remove it from the current editing environment.

	3.
	Click on Back to Main Menu to accept your settings and return to the Main Menu.


Back Env -> Settings
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Text Items - Use this option to select a feature class and text item.

To Select a Text Item

	Step
	Description

	1.
	Click on Back Env, then Settings, then Text Items.

	2.
	Click on a feature in the left box, and then select the item whose value is to be displayed from the right box and click on Apply.


Symbol Items - Use this option to select a feature class and symbol item.

	Step
	Description

	1.
	Click on Back Env, then Settings, then Symbol Items.

	2.
	Click on a feature in the left box, and then select the item whose value is to be displayed from the right box and click on Apply.


Back Env -> Identify Setup - Select Identify Setup to select a background cover, feature type, and items. Only one background cover and feature class can be identified.  Up to 20 items may be selected. If more than 20 items are selected, all items will be displayed. If no items are selected, all items will be listed. Select background coverage from the top menu, and then build a list of selected items for the edit cover.
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Figure 5.28:
Identify Setup

Back Env -> Identify One – Use to identify one background feature. Click on a background feature for a listing of the selected items for that feature. If no items have been selected, all items will be listed. A background cover and feature must be selected before using this option.

Back Env -> Identify Many - Use to identify many background features.  Click on each background feature for a list of the selected items for that feature.  If no items have been selected, all items will be listed.  A background cover and feature must be selected before using this option.   The standard keyboard and mouse actions are available and displayed in the ARC status window.
Select
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Select -> One - Select one edit feature (of the current edit feature class) by pointing and clicking.

Select -> Many - Select multiple features by pointing and clicking repeatedly. The ARC status window displays additional actions that may be invoked from the keyboard or the mouse while in this mode:

Select (1 or left mouse button) - Add to the selected set.

Next (2 or middle mouse button) - Cycle the most recently selected feature among those within the current edit distance of the cursor (i.e., within the circle centered on the cursor cross-hairs.)

Who (3 or right mouse button) - Displays the User ID and other info about the last selected feature in the ARC status window.

Quit (9 or control-right mouse button) - Stop selecting features.

Select -> Box - Select multiple features by drawing a box around them. Point and click once to define one corner of the box, then point and click again to define the diagonally opposite corner.  Those features crossed by the box will be selected. 

Select -> Polygon - Select many features by drawing a polygon around them. Only those features fully enclosed by the polygon will be selected.  The ARC status window displays additional actions, which may be invoked from the keyboard or the mouse while in this mode:

Enter (1, 2, or left or middle mouse buttons) - Define a vertex of the polygon.

Remove Last Point (4 or shift-left mouse button) - Remove the last vertex defined.

Remove Polygon (5 or shift-middle mouse button) - Remove the polygon and start over.

End (9 or control-right mouse button) - Complete polygon definition, select circumscribed features.

Select -> By Path - Select arcs based on the shortest path between two arcs.  Use the cursor to select the beginning arc and ending arc in the path.

Select -> By Expression - Use to create a selection expression (Figure 5.29).
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Figure 5.29:
Expression Generator

The expression may be typed directly into the text box in the center of the screen or "built" using the mouse as follows:

To Build a Selection Expression

	Step
	Description

	1.
	Click on an item in the left box.

	2.
	Click on an operator in the center of the screen.

	3.
	Click on a value from the right box, and then click on Accept.  A simple expression is built in the window in the center of the screen.


You may also build complex expressions or perform operations using other controls in this box.  See "Logical Selection" and "Logical Expression Format" in the on-line ArcInfo Help Index for additional information.

Select -> Alter Selection - Reverse the selected set (i.e., selected features are change to unselected, and unselected features are changed to selected.)

Select -> Select All - Select all features of the edit feature class.

Select -> Highlight Selected - Highlight selected features of the current edit feature in the chosen highlight color. The highlight color can be set in the View-Options menu. The default highlight color is yellow.

Identify

[image: image62.wmf]Identify Setup

One

Many

Selected


Identify-> Identify Setup – Use to select a feature class and associated item values from the current edit coverage to be displayed when Identify is performed.  If no items are selected or Identify is selected prior to setting Identify Setup, all items will be listed.  Up to 20 items may be selected.  If you select more than 20, all will be displayed.

To Select Items for Display

	Step
	Description

	1.
	Click on Identify, then Identify Setup.

	2.
	Click on a feature class in the left box.

	3.
	Click on an item in the center box to add it to the right box.

	4.
	Click on Apply.


To Remove Items from Display

	Step
	Description

	1.
	Click on Identify, then Identify Setup.

	2.
	Click on an item in the right box.

	3.
	Click on Remove Selected to delete the item.

	4.
	Click on Apply.


Identify -> One – Select to identify one feature.  Click on a feature for a list of the selected items for that feature.  If no items were selected, all items are listed. 

Identify -> Many – Select to identify many features.  Click on each feature for a list of the selected items for that feature.  If no items have been selected, all items will be listed.  The standard keyboard and mouse actions are displayed in the ARC status window.

Identify -> Selected – Use this option to identify features that are currently selected.

Tables
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Tables -> Form Setup - Select to set up forms for editing existing feature attribute tables for the current edit cover.  The items selected in each feature class for the current edit cover will be displayed in a menu when you click on the Update button on the Default Tools tool bar.

The default setup displays all fields for editing. (The list of active items is built using Identify – Identify Setup, described earlier in this section.)  Note: You may set up forms for all the features in the current edit cover in one session.  However, only the form for the attribute table of the current edit feature will actually be displayed when you click on the Update Attributes button.  The Form Setup is not saved as part of the environment in the ‘Environment Save/Retrieve’ functions.
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Figure 5.30:
Form Setup

Tables->Cursors

Open – Opens a cursor for selected features, and selects the first feature in the set. 

Next – Selects the next feature in the selected set. 

First – Selects the first feature in the selected set. 

Close – Closes the cursor for the selected features, restoring the original selected set.

Tables->Relates - Relate Manager – Starts the ArcTools Relate Manager program.

Geography
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Geography -> Add - Use to switch to an interactive display mode for adding new features based on the current edit feature. The ARC status window displays options available for the current edit feature while in this mode.  For arcs, these include the following:
Vertex (1 or left mouse button) – Add a vertex at the cursor location.

Node (2 or middle mouse button) – Add a node at the cursor location. Arcs must begin and end with nodes.

Curve (3 or right mouse button) – Add a section of a circle.

Delete Vertex (4 or shift-left mouse button) – Delete the last vertex added.

Delete Arc (5 or shift-middle mouse button) – Delete the entire arc currently being added.

Quit (9 or control-right mouse button) – Quit adding arcs.

For additional information about ADD options, see the ArcInfo on-line help.

Geography -> Delete

Select Delete to delete previously selected features. A confirmation screen showing the type and feature and number of elements to be deleted prompts the user to confirm the deletion.

Geography -> Move

Select Move to move previously selected features to a new location without rotation. Select the point to move from and the point to move to.

Geography -> Rotate

Select Rotate to rotate previously selected features. Use the cursor to define the pivot point and the rotation angle on the display window.

Dynamically Segmented
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All DynSeg operations require that the current 

edit feature be a route system.  "Source" in the 

context of these operations is synonymous with 

"relate".  Thus, adding a new source event is really 

defining a relate between the route system RAT and

an event table.  Once the source has been added, all

events in the specified event table become available.


Event sources are temporary and exist only during the current ARC session unless explicitly saved. Note: To display events using a lookup table, the user must first create the lookup table using <event source item name> and “SYMBOL” as fields. 

DynSeg -> New Source - Select to add a new event source.

To Select a New Source

	Step
	Description

	1.
	Click on DynSeg, then New Source.

	2.
	Enter Event Name to identify the relate.  (Limit 8 characters.)

	3.
	Click on Event Type (type of data to be related).  Select from: 

Linear - has both From and To locations; Continuous - has only To locations; or Point - point event data.

	4.
	Click on Event File that contains the event data.  Only INFO files in the current workspace are listed.

	5.
	Click on Relate Type.  Select Ordered if event table is sorted on the Event Table Relate Key (below) otherwise select Linear.  Note: Ordered relates are faster.

	6.
	For Event Table Relate Key, enter item in the event table that will be related by the Route Table Event Key in the RAT.

	7.
	Enter name of item in the event table that is the source of the From Measure of the route system's linear measures.

	8.
	Enter name of item in event table that is the source of the To Measure of the route system's linear measures.
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For more complete information about the fields above, see the on-line ArcInfo Help for the ARC Eventsource command.

DynSeg -> Load Source - Select to restore a previously saved event source.
To Restore an Event Source

	Step
	Description

	1.
	Click on DynSeg, then Load Source.

	2.
	Right-click in the text entry box for a list of INFO tables in the current workspace.

	3.
	Click on the table with the relate information to be added to the current environment, and then click Accept.


DynSeg->Drop Source - Select to drop an event source.  The screen will look identical to the New Source screen described above, however, only the Enter Event Name field is operational.  The remaining fields are for display only.
To Drop an Event Source

	Step
	Description

	1.
	Click on DynSeg, then Drop Source.

	2.
	Right-click in the Enter Event Name field for a list of current event sources.

	3.
	Click on the source to be dropped, then click Accept.


DynSeg -> Save Source - Select to save the current event source to an INFO table. Enter the name of the table when prompted.  Overwrite confirmation will be requested if needed.

DynSeg -> Export Routes - Select to export the current edit feature route system to an output arc coverage.  This tool allows the user 2 choices, it can either be run to export the routes to a new coverage with the route attributes associated with the new arcs, or it can be run to associate a selected group of Infra Linear Events and values with the route information to the arcs.  The second option can only be run with a route coverage that is connected to the Infra database.  Arcs belonging to a route are merged together and output as one arc.  User ID and any user-defined attributes from the RAT of the input route system are copied to the arcs of the output cover. 

Once the tool is started the user will need to make a choice about how they would like the routes to be exported.
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Figure 5.31:
Confirmation Screen

If the user chooses to export the routes without the Infra linear events, the following menu will appear.
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Figure 5.32:
Export Route System

If the user chooses to export the routes with the Infra linear events, the following menu will appear to allow the user to select the linear events to be exported.
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Figure 5.33:
Export Route System and Attributes

Once the tool has finished, a coverage with the route attributes will have been created.

Note: The output cover is not clean, since routes in the input route system may have overlaps and intersections. Use CLEAN to rebuild topology.

DynSeg -> Export Events - Select to export events for the current route system using a previously defined current event source in one of three ways:

Arcs - Exports events to new arc coverage.  No user-defined items in the AAT of the input coverage are exported to the output cover.  The items from the event table are added to the AAT of the output cover.  Click on Arc, specify an event source (right-click for a pop-up list), and then specify a new output coverage name.

Route System - Exports events as a new route system within the current edit cover.  Individual routes for the output route system are defined for each event section of the input route system.  No user-defined attributes from the input RAT are exported to the output RAT.  However, the output RAT User-ID is set to the value of the input route system subclass#, thus allowing relates to values in the input RAT, if desired. Also, all items from the event table are added to the output SEC.  Click on Routes, specify an event source (right-click for a pop-up list), and then specify a new output route system name.

Points - Exports point events from the specified event source to a new cover. All items from the event table are added to the PAT of the output cover.  Click on Points, specify a point-event event source (right-click for a pop-up list), and then specify a new output point coverage name. NOTE: If a linear or continuous event source is specified, no cover will be created even though the SDI status bar indicates the point coverage has been successfully created.

Utilities
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Utilities->Transfer Setup - Select to set up the transfer environment. Transferring is one way to copy feature attributes and/or coordinates between coverages, however, use this process carefully, as results are not always as expected.

To Set up the Transfer Environment

	Step
	Description

	1.
	Open the cover to transfer from, make it the current edit cover, and set the edit feature to anything other than "None".

	2.
	Click on Utilities, then Transfer Setup.  (Figure 5.34)

	3.
	Click on a transfer cover in the scrolling list at the top.

	4.
	Select transfer feature from scrolling list in the left box.

	5.
	Select transfer items from the list in the center box to add them to the list in the right box for transfer.  The items are checked to ensure all selected items exist in the edit cover.

	6.
	Click on Additional Features to specify these additional transfer options:

- Transferring from one-to-one or one-to-many features  (Default: one-to-one).

- Transferring attributes, coordinates, or both (Default: attributes only).

- Transfer symbols (default: symbolize origin feature = 3 (generally green, depending on the currently selected symbol set)).

	7.
	Click on Apply to accept your selections.  After a transfer environment has been set, use the Transfer option (described below) to transfer item values.
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Figure 5.34:
Transfer Setup

To Remove Items From the Transfer Environment

	Step
	Description

	1.
	First, open the cover to transfer from, make it the current edit cover, and set the edit feature to anything other than "None".

	2.
	Next, click on Utilities, then Transfer Setup.

	3.
	Click on a transfer cover in the scrolling list at the top.

	4.
	Select the transfer feature from the scrolling list in the left box.

	5.
	Select transfer items from the list in the right box to be removed from the transfer environment, and click on Remove Selected.

	6.
	Click on Apply to accept your changes.


Utilities -> Transfer - Select to transfer item values from the transfer cover and feature (selected in Transfer Setup above) to the edit cover.  Use the left mouse button to click on the feature to transfer from.  Use "2" or the middle mouse button to click on the feature to transfer to.  Other key and mouse options are listed in the ARC status window.  For more detailed information, see the ArcInfo on-line help for the ArcEdit Transfer command.

Additional transfer buttons can be found on the ARCS and ROUTES tool bars, denoted by an icon that looks like a "T" under a rubber stamp. 

Utilities -> Put Features  - Select to copy selected features to a selected coverage.  You can specify a subclass to put features into if the current edit feature is Annotation.  You may not copy Routes, Sections, or Nodes.
To Put Features in a Selected Coverage

	Step
	Description

	1.
	Click on Utilities, then Put Features. (Figure 5.35)

	2.
	Select the cover to which features will be copied.  To put features into a new coverage, select OTHER from the list of available coverages and you will be prompted for a name.

	3.
	Click on the PUT command.
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Figure 5.35:
Put Features

Utilities -> Get Features - Select to get features from another cover and append them to the current edit cover.  You can specify the subclass to place features into if the current edit feature is Route, Section, or Annotation. You may not copy Nodes. 

Utilities -> Create Features – Use to select the type of feature to create.

Anno, Region, and Group - You will be prompted for a subclass name.  A "createfeature featuretype.<subclass>" command is issued.

Arc, Node and Label - If the feature does not exist, an "editfeature featuretype" command is issued.

Route - A new route system is created on the current edit coverage.  You will be prompted for the new route system subclass name, followed by this screen:
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Empty - Creates an empty route system containing no routes.  To add routes, use a single route creation method, such as the ArcEdit "makeroute" command.

From Arcs - Issues a bulk create using the ArcEdit  "measureroute" command (Spatial Data Preparation (SDP) methodology uses the Arc "arcroute" command).  A primary difference between measureroute and arcroute is that measureroute will calibrate routes based upon one item from the arc attribute table (the default is length).  Arcroute does not perform a calibration.  Routes created with arcroute are calibrated using the ArcEdit "remeasure" command, including two items representing the low and high value for the calibration.

If you use the Create Feature function for bulk creating routes for use with Travel Routes, remember to recalibrate all of the created routes (a tool is available on the Travel Routes tool bar).

To Create a New Route System From Arcs

	Step
	Description

	1.
	Click on Utilities, then Create Features.

	2.
	Select Route as the feature to be created.

	3.
	Click on From ARCS.  The Create System screen will be displayed (Figure 5.36 below).
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Figure 5.36:
Create System

	Step
	Description

	4.
	Right-click in the Group Arcs into Routes Using Item window for a list of items on the arc attribute table.  Select an item to be used to group arcs into routes (e.g., Road Number).

	5.
	For Enter Output Route Item, enter the name for the item used in the 'Group Arcs' selection.  This item represents the value used to group arcs into routes.

	6.
	Right-click in the Measure Routes Using window for a list of items off the arc attribute table.  Select the item to use for the route calibration.


	Step
	Description

	7.
	Select Coordinate Priority - specify the map orientation to set route direction by.  For example, if UL were selected, the route direction would be set with the end that is closest to the UL being the beginning of the route.  Normally, after a bulk create is issued each route direction should be validated.

  UL - Upper Left

  UR - Upper Right

  LL - Lower Left

  LR - Lower Right

	8.
	For Create Routes with, select:

Continuous Measures (arcs are continuous only), or Allow Gaps in Measures (arcs are not required to be continuous).

	9.
	Include Arcs with Item - select Blank or Not Blank to identify if arcs that have null or zero in the item selected above to group by (Step 4) will be used to create routes.  The Blank option allows arcs with a null or zero in the item to be grouped together into a route.  The Not Blank option will not use those arcs in a route.

	10.
	When all selections have been made, click on Accept.  The current edit coverage is saved and a build is run as lines and nodes.  A command is issued to create the new route system.


Windows
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Select General Tool Bars for a list of tool bars available for general GIS functions.  By default the Zoom Tool Bar and the Menu Bar (containing Default Tools) are already displayed under the SDI main menu.

To select a tool bar, click in the box to the left.  Reposition the tool bar to a convenient location by dragging it by the title bar.  Descriptions of the tools on each tool bar can be found under the Tool Bars section below.

Windows -> Infra Tool Bars 
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Select Infra Tool Bars for a list of tool bars specific to the Infra application.  With each new Infra release, the toolbars associated with Infra functionality will appear in this menu.  One selection, the Start ArcView function, was added to allow users to start the ArcView application and Infra extensions while SDI is running.

Windows -> Application Tool Bars - Select for a list of tool bars used by applications other than Infra.  Any menu files existing in /fsapps/fsother/gis/sdi, are placed in this menu.  These files are supported by the entities that created them, not by Infra.  See the Infra Web Page for more documentation about how to create modules to run from the SDI Application Tool Bar.

Windows -> Realign Windows - Select to return all the SDI windows to their original position, with the exception of the main SDI pull-down menu.  This menu is the main thread to SDI, and cannot be automatically repositioned.

Windows -> New Window - Use to open another ArcEdit display window.

Windows -> ArcEdit Command Line - Select to open a window that can be used as an ArcEdit command line to type commands directly to ArcEdit.  Remember that many of the processes within SDI build upon each other and using the command window bypasses this feature.

Windows -> Status Window - Use to open the status bar window if it is not already open.

Help
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Help ->About - Provides information about SDI, the version, and its developers. 

Help ->Online 


Travel Routes Toolbar - Starts the SDI Travel Routes Users Guide.


Range Toolbar - Starts the SDI Range Users Guide.

Tool Bars 

Default Tool Bar

The default tool bar, on the left below the main menu bar, contains buttons frequently used for general operations.  This tool bar is also called the "Menu Bar" on the list of General Tool Bars under the Windows option on the Main Menu Bar.  Each option is described below.
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Identify Features - If a set of features has been selected, this tool displays a list of attributes for those features.  If no features have been selected, the user is prompted to select, then press '9' to display a list of attributes for those features.

Select Features - This tool allows one or more features to be selected.  Press '9' to end selection.

Select Box - This tool allows features to be selected by drawing a box.  Click on two points to define opposite corners of the box.  All features contained within the box are selected.

New Window - This tool opens another ArcEdit display window.

Delete Feature - This tool deletes any feature currently selected.

Undo Change - This tool reverses the last change made, incrementally back to the last save in the current editing session.

Calculate Distance Between Points - This tool calculates the distance between two points.  Click to identify each point; the distance is displayed in the status bar.

Update Attributes - This tool displays a form allowing attributes for the current edit feature to be edited.  All attributes are included unless the form is altered using the Tables -> Form Setup option on the main menu bar.

Zoom Tool Bar

The zoom tool bar, in the center of the screen below the main menu bar, contains buttons used to alter the area displayed on the screen.  Each option is described below.

[image: image81.wmf]Zoom in by Box

Zoom in by Pointing

Zoom out by Pointing

Zoom to Maximum Extent

Pan by Pointing

Pan by Grabbing

Zoom to Previous Area

Zoom to Selected Features

Refresh Screen


Zoom in by Box - Click on two points representing opposite corners of a box.  The display area is changed to the box extents.

Zoom in by Pointing - Zoom into an area by pointing at its center.  The display zooms incrementally; press '9' to stop zooming.

Zoom out by Pointing - Zoom out of an area by pointing at its center.  The display zooms out incrementally; press '9' to stop zooming.

Zoom to Maximum Extent - This tool causes the display area to be adjusted to the maximum display extents.

Pan by Pointing - Click on one point to make it the center of the display area.

Pan by Grabbing - Click and drag the display area.

Zoom to Previous Area - This tool changes the display area back to the previous display area.

Zoom to Selected Features - This tool alters the display area to include all selected features, as large as possible.

Refresh Screen - This tool redraws the display area.

Edit Tool Menu Bar

The Edit Tool menu bar, on the right below the main menu bar on the SDI screen, contains menu choices for editing spatial features.  Each option is also available on one of the General Tool Bars under the Windows option on the Main Menu Bar.  These tool bars are described below.
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The Arcs pulldown menu displays options to edit existing arcs.  The current edit feature must be set to arcs.  Follow the directions displayed in the ARC status window for each option.  These options can also be found on the Arc Tool Bar.

The Vertices pulldown menu displays options to edit vertices in existing arcs.  The current edit feature must be set to arcs.  Follow directions displayed in the ARC status window for each option.  These options can also be found on the Vertex Tool Bar.

The Polygons pulldown menu displays options for editing polygons.  Some options are available just for a polygon edit feature, and some for both arc and polygon edit features, with slightly different functionality.  There are two choices in the pulldown menu for creating regions from polygons, either from a selected set or from and item value.  Again, follow directions in the ARC status window for the following options.  Most of these options can also be found on the Polygon/Region Tool Bar.

The Regions pulldown menu provides additional options for editing region. <subclass> features when the edit feature is region.<subclass>.   Follow directions in the ARC status window.  These options can also be found on the Polygon/Region Tool Bar.

The Routes pulldown menu provides additional options for editing routes.  Follow directions in the ARC status window for each option.  These options can also be found on the Route Tool Bar.

Arc Tool Bar
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Add Features - Allows new features to be created.

Move Features - Moves a selected feature.

Split Arc - Splits a previously selected single arc into two arcs by clicking at a point to insert a node.  Each resulting arc will have identical attributes (i.e., the node will be a pseudo node.)

Unsplit Arc - Removes pseudo nodes (i.e., nodes with exactly two arcs attached) from a previously selected group of arcs.  If removing a pseudo node would result in a single arc with more than 500 vertices, the operation will not be performed on that node.  Note: Resulting attributes can be unpredictable.

Reshape Arc - Allows reshaping of a previously selected arc by pointing and clicking to define a new segment.  The new segment must cross the pre-existing arc at least once.  Results can be somewhat unpredictable with this function and users are encouraged to practice in a scratch coverage first.

Extend Arc - Extends a previously selected arc from one or both ends up to the distance defined by the cursor in the display, if doing so will intersect an existing arc. Note: If the selected arc is extended, it will be intersected with another arc (i.e., a node will be added) regardless of the Edit - Intersect Arcs setting.  The arc will not be extended beyond the point of intersection.

Rotate Features - Rotates a selected feature.

Snap Arcs - Connects dangling nodes on arcs within the defined snap tolerance (snapping them together).

Delete Feature - Deletes any feature currently selected.

Transfer - Transfers attribute items from one arc to another arc.

Flip (on Edit Tool Menu bar, not Arc tool bar) - Reverses the direction of previously selected arcs; that is, switches the From and To Node records for each arc.

Vertex Tool Bar
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Add Vertex- Inserts a vertex at the cursor in a previously selected arc and re-aligns the segment between the two closest existing vertices closest to pass through the added vertex.   Multiple vertices may be added by repeated clicking.

Move Vertex - Moves a vertex and re-aligns the segments.

Delete Vertex - Turns on display of vertices in a previously selected arc and allows selection and deletion of one or more vertices.

Densify Vertices - Adds vertices to arcs at a spacing set by the user. [Not Implemented].

Generalize Vertices - Removes vertices from arcs using a user-specified line generalizations operator and tolerance.  [Not Implemented].

Polygon/Region Tool Bar

[image: image85.wmf]Build Polygons

Merge Polygons

Split Polygons

Make Region

Append Region

Split Region


Build Polygons - Builds polygons from arcs, updating topology and creating a PAT if none exists.  Available for edit feature arc, polygon or region. <subclass>.

Merge Polygons - Merges previously selected, adjacent polygons into one by deleting interior arcs.  Available only for edit feature polygon.  Note: Attributes in the resulting superpolygon may be unpredictable.

Split Polygons - Allows a previously selected polygon to be divided by drawing new arcs on-screen when polygon is the edit feature, or allows splitting a previously selected arc when arc is the edit feature.  When polygons are split, topology is rebuilt.

Make Region - Creates a region from previously selected polygon(s) and prompts the user for a subclass name.  Available only for edit feature polygon.

Append Region - Allows polygons to be appended to a previously selected region in the current region. <subclass>.

Split Region - Allows a previously selected region to be divided by drawing new arcs on-screen when region. <subclass> is the edit feature, or allows splitting a previously selected polygon when polygon is the edit feature.  Polygon topology is rebuilt.

Route Tool Bar
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Add New Route - Adds a new route (for edit feature route.<subclass>).  Select arc(s) to add to the route system, then point and click on the point for start priority for route measures.  Note: If no arcs are selected, edit feature will be left as arcs, not route.<subclass>.  For edit feature arc, this option functions exactly like Geography -> Add: arcs are added to the arc feature class but not to any route system.

Append an Arc - Appends pre-existing arcs to previously selected route(s) (for edit feature route.<subclass>.)  Point and click using options displayed in the status screens to select arcs to append.  Note: If multiple routes have been selected, each arc selected will be appended to each route.  Routes altered with this option must be remeasured.

Split a Route - Splits a route (for edit feature route.<subclass>).   User is prompted to select the beginning and ending sections of a path along the route to be split.  The sections along the path are removed from the original parent route and are defined as a new route in route.<subclass> with the same user-defined attributes (including user ID, BMP, and EMP) as the original route.  The geometry of the original route may be split or just shortened, depending on the position along the route of the path selected to be split. Routes altered with this option must be remeasured.

Flip a Route - Reverses the direction of previously selected arcs; that is, switches the From and To Node records for each arc on a route. 

Remeasure a Route - Remeasures previously selected routes using default values for REMEASURE: "LENGTH" (and, therefore, coverage units) from the AAT.  Current start priority, lowest measure value on the route for the start value, and no gaps in assigned measures are used to compute measures. 
Warning: Do not use this to remeasure routes used with Travel Routes!

Remeasure Routes and Sections - Remeasures selected routes using default values for REMEASURE except prompting the user for the start priority from which the route will be remeasured. This option is useful for re-aligning sections of a route in the same direction.  However, the section end point nearest the cursor when the mouse button is clicked will be assigned the start position, even if this end point is not an end point of the route. In that case, the new measures on the route will increase in both directions away from this "interior" start point.  Warning: Do not use this to remeasure routes used with Travel Routes!

Snap Tolerance for Sections - Sets the snap tolerance (maximum distance) for sections. 

Update Route Attributes - Calls a form menu to edit attributes of previously selected arc(s) or route(s), depending on the edit feature. This option functions just like the Update Attributes button on the Default Tools tool bar. The update form that appears may be set up beforehand in the Tables -> Form Setup option available from the Main Menu Bar: Select items in the desired feature class to be displayed in the form menu when the Update option is chosen. The default is that ALL fields will be displayed for editing.  (The list of active items is built as in Identify -> Edit Cover -> Items, above.)

Transfer - Transfers the attribute items from one route to another route.
Move End (on Edit Tool Menu bar, not Route tool bar) - Allows the user to interactively move the endpoint of a previously selected route. This option is most easily used if section arrows are displayed (View - Display -> Draw Environment, above.)  Note the location of the endpoints of the desired section, and follow the status window prompts.   Point and click to select the section whose end point will be moved, then click near and drag the desired end to its new position along an existing arc on which the route has been previously defined.  (A section may not be extended beyond either endpoint of any adjacent section on the route, nor further than the length of the underlying route arcs.) The end closest to the cursor when the mouse button is depressed will be the one moved, and it will be moved to the point on the arc closest to where the button is released. Therefore, it's entirely possible with this feature to reverse the direction of a segment when attempting to merely change its length or end point position.  Also, since any segment may be selected for altering, not just route end segments, using this feature carelessly may inadvertently create a discontinuous route.  Routes altered with this option must be remeasured.

Append Section (on Edit Tool Menu bar, not Route tool bar) - Appends sections of other routes to a previously selected route. Click on section to append. The appended section is removed from the parent route. Note: If multiple routes have been selected, each section selected will be appended to each route.  Routes altered with this option may need to be remeasured, depending on the desired result.

Route Systems (on Edit Tool Menu bar, not Route tool bar) - Contains these options:

Copy - Uses ArcEdit to copy selected routes to a new or existing route system.  User is prompted for a new subclass name and asked to confirm appending if named subclass already exists.

Rename - Uses ARC to rename, and the entire edit feature route subclass to a different name.

Delete - Uses ARC to delete the entire edit feature route subclass.

Select Tool Bar
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The Select tool bar contains buttons frequently used for selecting features.  Each option is described below.

Select One Feature - Allows one feature to be selected.  Press '9' to end selection.

Select Many Features - Allows several features to be selected.  Press '9' to end selection.

Select Features to be Added - Allows one or more features to be added to a selected set.  Press '9' to end selection.

Select by Box - Allows features to be selected by drawing a box.  Click on two points to define opposite corners of the box.  All features contained within the box are selected.

Select by Polygon - Allows features to be selected by drawing a polygon around them.  Click on multiple points to define the polygon, then press '9' to end selection.  Only those 
features contained within the polygon are selected.

Select by Path - Selects arcs based on the shortest path between two arcs.  Use the cursor to select the beginning arc and ending arc in the path.

Select by Expression - Calls the Expression Generator screen which allows entry of a select statement.
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Unselect Many - Allows features to be removed from a selected set. Click on the selected features to unselect them, then press '9' to end.

Unselect All Features - Unselects all features from a selected set.

Cursor Tool Bar
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The Cursor tool bar contains buttons frequently used for moving the cursor.  Each option is described below.

Go to First Feature - Moves the cursor to the first feature in a selected set.

Open a Cursor - Opens a cursor for selected features and selects the first feature in the set.

Close a Cursor - Closes the cursor for the selected features, restoring the original selected set.

Go to Next Feature - Moves the cursor to the next record in the selected set.

Infra Tool Bars

Travel Routes Tools

The Travel Routes Tool bar contains the tools to use for a dynamically segmented route system to connect to the Infra database.  For more information about these tools, see the SDI chapter in the Infra Travel Routes User Guide.
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Write Selected Set - Writes the selected set of routes so they can be passed between Infra technologies.

Read Selected Set - Reads the selected set passed from another Infra technology into SDI.

Connect Routes - Creates the link between the routed roads coverage in SDI and the Infra Oracle database.

Identify Routes not Connected - Creates a report of the routes not connect to the Infra Oracle database.

Check Route Connections - Checks the routes and the Infra Oracle database to make sure they are storing the same data in duplicate fields.

Post Oracle Changes to Routes - Updates the route coverage with any changes in the Oracle Route Manager form.

Create a Route - Allows selected arcs to be made into a route.  The edit feature must be arc for this tool to function properly.

Calibrate Routes – Calibrates the routes based on the beginning and ending measure points entered into the Infra Route Manager Form in Oracle.

Generate a Secondary Route System - Creates secondary route systems based on a linear event on the original route system.

Flip Underlying Arcs in Route System as Safety Net - Creates a safety net for the route system.  It flips the arcs in the underlying arc topology to match the direction of the routes in the currently selected routes system.

Generate a GIS Point Coverage - Generates a point coverage from route feature events in the Infra Oracle database.

Midpoint Calibration - Uses existing midpoint coverage to calibrate routes using known points along the routes.

Get Measure Point - Returns the measure point for a point selected along a route.

Feature MP to Oracle - Uses existing feature coverages that have been connected to Infra to update the Oracle feature table with the measure points of the features generated from GIS.

Identify Duplicate Route Numbers - Creates a report of the routes with duplicate route numbers in the GIS coverage.

Identify Missing Measure Points - Creates a report of the routes in the GIS coverage which do not have a BMP or EMP, or where the EMP is less than or equal to the BMP.

Identify Routes Missing on the RAT and in Oracle - Creates a report listing the routes with no matches on the RAT for the currently selected route system and the routes with no matches in Oracle.

Review Calibrated Route Lengths – Creates a report listing the routes with calibrated lengths greater than the longest route in the route system.

Compare GIS Lengths to Measure Points - Creates a report listing the routes for which the GIS length and the Oracle measure points differ by a specified percentage.

Clip Linear Events on Route System to a Polygon to Calculate Miles - Creates a report listing the miles of the selected linear event within each polygon of the selected polygon coverage.

Generate a Map of Routes by Surface Type - Generates an ArcPlot map for a specified surface type within a polygonal boundary or a quad.

Range Tools

The Range Tool bar connects Range allotments to the Infra database.  For more information about these tools, see the SDI chapter in the Infra Range User Guide.
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Write Selected Set - Writes the selected set of allotments so they can be passed between Infra technologies.

Read Selected Set - Reads the selected set that was passed from a different Infra technology into SDI.

Connect Allotments - Creates the link between the allotment coverage in SDI and the Infra Oracle database.

Generic Tools

The Generic Tool bar connects point or polygon features to the Infra database.
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Write Selected Set - Writes the selected set of features so they can be passed between Infra technologies.

Read Selected Set - Reads the selected set that was passed from a different Infra technology into SDI.

Connect Features - Creates the link between the features in the GIS coverage in SDI and the Infra Oracle database.
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